- Working Productively in Bash's Vi Command Line Editing Mode
- The Definitive Guide to Bash Command Line History
- Sed - UNIX Stream Editor - Cheat Sheet
- Ed - Unix Text Editor - Cheat Sheet
- Plain Text Versions of Sed, ed and AWK Cheat Sheets
- A Unix Utility You Should Know About: Netcat
- Screen VT100/ANSI Terminal Emulator Cheat Sheet
- A Unix Utility You Should Know About: Pipe Viewer
- Perl Special Variable Cheat Sheet
- A Unix Utility You Should Know About: lsof
Tuesday, December 28, 2010
Howto Speed Up Your Work Using Linux Command Line Tools
See Also:
Using Multiple User Profiles in FireFox
See Also:
- Main Profiles Howto of Firefox
- Managing profiles how to create/delete new/old profiles.
- Backing up your information how to back-up/restore profiles and move profile info to a different folder/computer.
- Recovering important data from an old profile describes what info is stored in the files in a profile and howto copy the files into a new profile.
Howto Setup FireFox4 beta 8 on Linux Fedora Core 14
1) Backup your current Firefox 3 profiles
tar -cvzf $HOME/mozilla-firefox-profiles-backup.tar.gz $HOME/.mozilla/firefox/
2) Change to root user for below actions:
3) Add repositories for downloading FireFox4 for FC14:
yum --nogpgcheck install http://rpm.livna.org/livna-release.rpm http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
## Remi Dependency on Fedora 14 ##
# These below repos didn't work out for me got error message saying system-release >=15 required for
# rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-rawhide.noarch.rpm
#rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-rawhide.noarch.rpm
## Fedora 14 ##
rpm -Uvh http://rpms.famillecollet.com/remi-release-14.rpm
Install Firefox4:
yum --enablerepo=remi list firefox4
yum --enablerepo=remi install firefox4
Create different Profile for Firefox4:
firefox --ProfileManager (Create 2 profiles "Default User" and "FF4")
Start Firefox with FF4 profile using command:
firefox4 -P FF4
Or start Firefox 3.6.x with command:
firefox -P 'Default User'
Reference:
http://www.if-not-true-then-false.com/2010/install-firefox-4-on-fedora/
http://www.fedorafaq.org/#installsoftware
Note: Found what I needed was the above steps. Got most of them from these above 2 sources. Either of them singly didn't work out for me so clubbing together the total install steps into this post
tar -cvzf $HOME/mozilla-firefox-profiles-backup.tar.gz $HOME/.mozilla/firefox/
2) Change to root user for below actions:
3) Add repositories for downloading FireFox4 for FC14:
yum --nogpgcheck install http://rpm.livna.org/livna-release.rpm http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
## Remi Dependency on Fedora 14 ##
# These below repos didn't work out for me got error message saying system-release >=15 required for
# rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-rawhide.noarch.rpm
#rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-rawhide.noarch.rpm
## Fedora 14 ##
rpm -Uvh http://rpms.famillecollet.com/remi-release-14.rpm
Install Firefox4:
yum --enablerepo=remi list firefox4
yum --enablerepo=remi install firefox4
Create different Profile for Firefox4:
firefox --ProfileManager (Create 2 profiles "Default User" and "FF4")
Start Firefox with FF4 profile using command:
firefox4 -P FF4
Or start Firefox 3.6.x with command:
firefox -P 'Default User'
Reference:
http://www.if-not-true-then-false.com/2010/install-firefox-4-on-fedora/
http://www.fedorafaq.org/#installsoftware
Note: Found what I needed was the above steps. Got most of them from these above 2 sources. Either of them singly didn't work out for me so clubbing together the total install steps into this post
Thursday, December 23, 2010
Networking Protocol, RFC and Administration Links
Introduction to Network administration
Email
1) Email Bible: Internet Email Protocols: A Developer's Guide [Paperback] by Kevin Jhonson
2) Top-Down Overview: Wood, D (1999). Programming Internet Mail. O'Reilly
3) Uses VB Source: Rhoton, J (1999). Programmer's Guide to Internet Mail: SMTP, POP, IMAP, and LDAP
4) Totally NT Oriented: Hughes, L (1998). Internet e-mail Protocols, Standards and Implementation. Artech House Publishers
Post Office Protocol - Wikipedia, the free encyclopedia
RFC 1081 - Post Office Protocol Version 3
RFC 2449 - POP3 Extension Mechanism
RFC 2595 - Using TLS with IMAP, POP3 and ACAP
RFC 2616 - Hypertext Transfer Protocol -- HTTP-1.1
RFC 2822 - Internet Message Format
RFC 3164 - The BSD Syslog Protocol
RFC 3207 - SMTP Service Extension for Secure SMTP over Transport Layer Security
RFC 3507 - Internet Content Adaptation Protocol (ICAP)
RFC 5034 - The Post Office Protocol (POP3) Simple Authentication and Security Layer (SASL) Authentication Mechanism
RFC 5321 - Simple Mail Transfer Protocol
1) Email Bible: Internet Email Protocols: A Developer's Guide [Paperback] by Kevin Jhonson
2) Top-Down Overview: Wood, D (1999). Programming Internet Mail. O'Reilly
3) Uses VB Source: Rhoton, J (1999). Programmer's Guide to Internet Mail: SMTP, POP, IMAP, and LDAP
4) Totally NT Oriented: Hughes, L (1998). Internet e-mail Protocols, Standards and Implementation. Artech House Publishers
Post Office Protocol - Wikipedia, the free encyclopedia
RFC 1081 - Post Office Protocol Version 3
RFC 2449 - POP3 Extension Mechanism
RFC 2595 - Using TLS with IMAP, POP3 and ACAP
RFC 2616 - Hypertext Transfer Protocol -- HTTP-1.1
RFC 2822 - Internet Message Format
RFC 3164 - The BSD Syslog Protocol
RFC 3207 - SMTP Service Extension for Secure SMTP over Transport Layer Security
RFC 3507 - Internet Content Adaptation Protocol (ICAP)
RFC 5034 - The Post Office Protocol (POP3) Simple Authentication and Security Layer (SASL) Authentication Mechanism
RFC 5321 - Simple Mail Transfer Protocol
Saturday, December 18, 2010
Study Notes RARP Protocol
Study Notes on Reverse Address Resolution Protocol:
(Reference Chapter 6: Internetworking with TCP/IP: Vol 1 Principles, Protocols and Architecture - 3rd Ed. by Douglas E. Comer)
1) RARP is used by diskless machines which can't "remember" their IP address after a boot.
They send a physical-address (ex: ethernet NIC card's unique id) to RARP server(s) which reply back with IP address for that particular physical address.
Note: A machine can query IP address for another machine by supplying that machine's physical address. ?? Used by subnet routers to setup routing tables for its children??
2) RARP uses only ethernet frames as it can't use IP/TCP protocols without an IP address.
On getting hold of the IP address it uses TFTP for loading the boot image from the remote image server.
3) Request Message broadcast by QueryingMachine (to RARP server) as an Ethernet Frame:
PREAMBLE,
SRC-ADDR=QueryingMachine- physical-address,
DEST-ADDR=broadcast-physical- address,
FRAME-TYPE=RARP,
FRAME-DATA=(REQUEST, QueryingMachine-physical- address, target-physical-address), //227 bits (28 Octets) long frame data
CRC
Note:
a) The Ethernet Frame Header may be processed only by NIC card, so the the QueryingMachine-physical- address is repeated in frame data so it's accessible to the O.S.
b) A QueryingMachine can also ask the RARP server to lookup a target-machine's IP address by supplying the target-physical-address.
In such a case the target-physical-address would be different from sender-physical-address. ??Could be used by subnet routers to setup routing tables for its children??
Reference:Fig 2.8 for diagram of Ethernet Frame in Comer)
TODO: Need to cross-check how 2 physical addresses of 48 bits (6 octets) each can fit into the 227bits (28 octet) frame data
4) Reply Message sent by RARP server to QueryingMachine as an Ethernet Frame:
PREAMBLE,
SRC-ADDR=RARPServer-physical- address,
DEST-ADDR=QueryingMachine- physical-address,
FRAME-TYPE=RARP,
FRAME-DATA=(REPLY, QueryingMachine-physical- address, target-physical-address, target-IP-address), // ?? Used to update a subnetting routers routing table ??
CRC
Note:
RARP server sends the target-IP-address to the QueryingMachine and NOT the target machine.
??Could be used by subnet routers to setup routing tables for its children??
5) RARP REQUESTs are retryed by QueryingMachine
a) Looping at periodic intervals to avoid server overload (used for critical remote boot situations)
b) fixed number of retries to avoid network flooding. (used in non-critical remote boot situations)
6) Flooding can occur in case of failed PrimaryServer. This is avoided as follows:
a) REQUEST flooding by QueryingMachine is avoided by Secondary Servers replying back only on the 2nd REQUEST.
b) REPLY flooding is avoided in case of failed Primary Server by Secondary Servers replying back with randomly differing delays of REPLY.
Subscribe to:
Posts (Atom)
